Website Compatibility

I decided not to put something like this into my last email to the tech support person regarding a broken job-seeking and -application website, since it’s as likely to piss them off as to help my cause. But I needed to say it:

You really shouldn’t be supporting browsers in the first place, you should be supporting standards. By every measure I’ve seen, simply doing so would basically guarantee compatibility with Safari, Firefox, & Chrome, and provide functional-if-not-pretty support for Internet Explorer, OmniWeb, and Opera. And I know it’s not the tech geek’s fault—it’s a policy decision. But that’s why there are standards, and I’m really getting sick of companies’ solution to their website not functioning being “use Internet Explorer”—as if that’s even an option if you don’t use MSWindows, or an appropriate response when barely half of people are using IE any more.

It’s doubly annoying when I discover that the only reason the website requires IE is because they’ve hard-coded it to check for IE. I’ve had 100% perfect functionality using Firefox on all but one “IE-only” website, just by having it identify as IE8 running on MSWindows 7. [And the one site I never tried that on was also claiming compatibility with IE5! Really? You’re maintaining compatibility with a webbrowser that was obsolete 9 years ago, and hasn’t seen 1% browser share since 2006? And yet not bothering with current webbrowsers that make up 40-50% of browser share?]